Potential impact for PetDesk Customers

Incident Report for PetDesk Status

Resolved

Per AWS: The issue is resolved and the service is operating normally at this time.
Posted Sep 03, 2026 - 17:11 PDT

Update

AWS has indicated they are seeing recovery and our monitoring and testing confirm that. We will continue to monitor this incident until they confirm resolution.
Posted Sep 03, 2026 - 16:17 PDT

Monitoring

Our engineering team is currently monitoring the impact of an Amazon Web Services (AWS) outage that may impact our systems directly or indirectly through dependent upstream providers. We will post status updates here as we have them.
Posted Sep 03, 2026 - 15:24 PDT