Phone Service Interruption

Incident Report for PetDesk Status

Resolved

Our provider has confirmed a resolution on their side and we have confirmed resolution for PetDesk Phones as well. We'll continue to monitor. If you experience any further issues, please contact support.
Posted Aug 14, 2026 - 07:06 PDT

Monitoring

An upstream provider for our Phones service is experiencing an outage. They have indicated that the root cause has been resolved. Inbound calls should be restored. We will continue to monitor.
Posted Aug 14, 2026 - 06:58 PDT