Intermittent Errors

Incident Report for PetDesk Status

Resolved

This incident has been resolved.
Posted Aug 09, 2023 - 10:30 PDT

Investigating

We are investigating reports of intermittent errors and performance issues with core PetDesk dashboard features.
Posted Aug 09, 2023 - 10:01 PDT
This incident affected: Provider Communications Dashboard.