Delayed data sync for multiple providers syncing through Covetrus

Incident Report for PetDesk Status

Resolved

This incident has been resolved.
Posted May 22, 2025 - 09:30 PDT

Monitoring

Covetrus Syncs are now fully recovered and operating normally. We expect tonight's sync run to resume normal operations and will monitor this activity.
Posted May 21, 2025 - 10:48 PDT

Identified

On May 15th, 5/15, Covetrus performed a release and applied sweeping updates across clinics, impacting numerous records.

The rollout duration caused PetDesk to flag these syncs as potential issues due to large-scale data changes. The safeguard was intentionally put in place, but it was triggered incorrectly in this case.

Our team worked through restarting and ensuring all delayed syncs were completed successfully, but some delays occurred between 5/15 and 5/19.
Posted May 18, 2025 - 10:00 PDT
This incident affected: Data Syncs (All Other PIMS (synced through Covetrus Connect)).