PetDesk Pay Service Degradation

Incident Report for PetDesk Status

Resolved

We've received no further reports of incidence and our upstream provider indicates that services are stable. If you are still having issues processing payments, please reach out to support.
Posted Apr 16, 2026 - 15:04 PDT

Update

Per our provider the system has been stabilized. We'll continue to monitor.
Posted Apr 16, 2026 - 11:00 PDT

Monitoring

Our upstream payments provider is experiencing an issue processing payments. We are monitoring the situation and will post updates here as they become available.
Posted Apr 16, 2026 - 10:05 PDT
This incident affected: PetDesk Pay.