Increased Errors

Incident Report for PetDesk Status

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 09:37 PDT

Monitoring

This was a residual effect tied to a third party dependency that affected a portion of requests. We've resolved the issue and will continue to monitor. If you continue to have any issues, please contact support.
Posted Jul 10, 2026 - 15:07 PDT

Investigating

Looking into an increase in errors that may be a residual effect of a previous outage from a third party provider earlier this afternoon. We're investigating.
Posted Jul 10, 2026 - 14:47 PDT