Intermittent Transaction Failures

Incident Report for PetDesk Status

Resolved

This incident has been resolved.
Posted Jul 19, 2023 - 07:58 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2023 - 22:15 PDT

Identified

We are aware of an issue with one of our partners that may be causing and increased error rate and/or timeouts when processing payments. We are working with the partner to resolve the issue
Posted Jul 18, 2023 - 15:24 PDT
This incident affected: PetDesk Pay.