PetDesk Dashboard

Incident Report for PetDesk Status

Resolved

The incident has been resolved and all systems are back to normal performance.
Posted Jun 10, 2026 - 08:01 PDT

Update

We're continuing to see degraded performance in our monitoring. Our team is working to restore services to full performance.
Posted Jun 10, 2026 - 07:30 PDT

Monitoring

The fix has been implemented and all services have been restored. We will continue to monitor performance.
Posted Jun 10, 2026 - 06:43 PDT

Investigating

We have failed over and have been seeing recovery for the last 10 minutes or so. Expect some lingering latency as everything settles. We continue to monitor.
Posted Jun 10, 2026 - 06:42 PDT

Identified

The issue has been identified and a fix is in progress.
Posted Jun 10, 2026 - 06:34 PDT

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 06:28 PDT

Investigating

We are currently investigating an issue impacting the Communications Dashboard.
Posted Jun 10, 2026 - 06:20 PDT
This incident affected: Provider Communications Dashboard.