This incident is now resolved! The bug fix has been verified and is currently in production. The PetDesk Communications Dashboard is now functioning as expected for all users. Thank you to those impacted for their patience!
Posted Apr 22, 2025 - 09:30 PDT
Update
For users still experiencing this issue, please try clearing cache/cookies as well as using the main dashboard login (rather than any bookmarked special pages). https://dashboard.petdesk.com/Account/Login
Posted Apr 22, 2025 - 08:01 PDT
Identified
The cause has been identified. Our team is actively working on getting the fix into testing; then we will send it to our users very soon. We want to ensure the fix we put out doesn't cause any problems, and are testing it thoroughly
Posted Apr 22, 2025 - 07:59 PDT
Investigating
We have been made aware that some, but not all, PetDesk Communications Dashboard users have reported being unable to load or log into the product. Our team began looking into the issue immediately!
Posted Apr 22, 2025 - 07:59 PDT
This incident affected: Provider Communications Dashboard.