Dashboard Performance and Availability

Incident Report for PetDesk Status

Resolved

We are pleased to report that the performance issue has been resolved! Pages on the PetDesk Dashboard will now load as expected, and performance has returned to normal. If you continue to experience problems, please reach out to PetDesk Support at support@petdesk.com.
Posted May 26, 2026 - 08:27 PDT

Identified

We have identified an issue with the performance and loading of the PetDesk Dashboard. Our team is currently investigating and working to resolve this problem. This incident will be updated with additional details once received.
Posted May 26, 2026 - 07:58 PDT
This incident affected: Login / Authentication (PetDesk Communications Dashboard Login) and Provider Communications Dashboard.