We applied a temporary fix and we are seeing a substantial improvement in performance. As part of this initial fix, the “new appointments” count on the left sidebar will temporarily display as 0. To see new appointments, please manually refresh the “Needs Attention” page. We are continuing to monitor performance and work on the full solution continues. Thank you for your understanding as we work to resolve this quickly!
Posted Dec 02, 2024 - 09:50 PST
Identified
We’ve applied an initial adjustment to improve performance and are continuing to work toward a full resolution. Thank you for your patience.
Posted Dec 02, 2024 - 09:04 PST
Investigating
We are currently experiencing system slowness, and our team is actively working to identify and resolve the issue as quickly as possible. Thank you for your patience and understanding.
Posted Dec 02, 2024 - 07:04 PST
This incident affected: Provider Dashboard web application.